<!DOCTYPE html><html lang="fr"><head><meta charset="UTF-8">
<title>Les codes MIDI: Program changes, Messages systèmes, SysEx</title>
<meta name="description" content="Quand on souhaite automatiser certaines tâches comme le changement d’un son ou le contrôle d’un pitch-bend, il est bon de savoir utiliser les codes MIDI. Cette page explique les principales données comme les messages de program changes ou les SysEx. ">
<style>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</style><script>function loadCSS(a,d,f,g){var b=window.document.createElement("link");var c=d||window.document.getElementsByTagName("script")[0];var e=window.document.styleSheets;b.rel="stylesheet";b.href=a;b.media="only x";if(g){b.onload=g}c.parentNode.insertBefore(b,c);b.onloadcssdefined=function(h){var k;for(var j=0;j<e.length;j++){if(e[j].href&&e[j].href.indexOf(a)>-1){k=true}}if(k){h()}else{setTimeout(function(){b.onloadcssdefined(h)})}};b.onloadcssdefined(function(){b.media=f||"all"});return b};</script><script>loadCSS("https://www.pianoweb.fr/css-java/style_afs_ads.css");</script><meta name="viewport" content="width=device-width, initial-scale=1.0"><meta name="Viewport" content="width=device-width, height=device-height, initial-scale=1.0, user-scalable=yes"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="apple-mobile-web-app-status-bar-style" content="default"><meta name="format-detection" content="telephone=no"><link rel="preload" href="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" as="script"><link rel="preload" href="https://www.pianoweb.fr/css-java/code-javascript-bdp.js" as="script"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><meta name="robots" content="noimageindex">

<meta property="og:title" content="Les codes MIDI: Program changes, Messages systèmes, SysEx">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.pianoweb.fr/les-codes-midi-program-changes-messages-systemes-sysex.php">
<meta property="og:description" content="Quand on souhaite automatiser certaines tâches comme le changement d’un son ou le contrôle d’un pitch-bend, il est bon de savoir utiliser les codes MIDI. Cette page explique les principales données comme les messages de program changes ou les SysEx.">
<meta property="og:image" content="https://www.pianoweb.fr/technique/le-code-midi-et-ses-petits-secrets-2.gif">
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="Les codes MIDI: Program changes, Messages systèmes, SysEx">
<meta name="twitter:url" content="https://www.pianoweb.fr/les-codes-midi-program-changes-messages-systemes-sysex.php">
<meta name="twitter:description" content="Quand on souhaite automatiser certaines tâches comme le changement d’un son ou le contrôle d’un pitch-bend, il est bon de savoir utiliser les codes MIDI. Cette page explique les principales données comme les messages de program changes ou les SysEx.">
<meta name="twitter:image" content="https://www.pianoweb.fr/technique/le-code-midi-et-ses-petits-secrets-2.gif">
<script type="application/ld+json">
 { "@context" : "https://schema.org",  "@type" : "EducationalOrganization",
 "headline" : "Les codes MIDI: Program changes, Messages systèmes, SysEx",  
 "url" : "https://www.pianoweb.fr/les-codes-midi-program-changes-messages-systemes-sysex.php", 
 "image" : "https://www.pianoweb.fr/technique/le-code-midi-et-ses-petits-secrets-2.gif",
 "author": { "@type": "Person", "name": "Piano Web" }, 
 "description": "Quand on souhaite automatiser certaines tâches comme le changement d’un son ou le contrôle d’un pitch-bend, il est bon de savoir utiliser les codes MIDI. Cette page explique les principales données comme les messages de program changes ou les SysEx."} 
 </script>
<link rel="canonical" href="https://www.pianoweb.fr/les-codes-midi-program-changes-messages-systemes-sysex.php"></head><body><a id="hautpage"></a>

<div id="global">
<div class="global-980">

<!--[if IE 9]><div id="IE9"><![endif]--><div class="haut-accueil"><div class="cadre-haut-2 ombre-texte"><span class="tr-acc-1">P</span><span class="tr-acc-2">IANOWEB</span><span class="tr-acc-3">.fr</span><span class="str-acc">&nbsp; &nbsp; "&nbsp;Espace Dossiers&nbsp;"</span><div class="publier"><div class="publier-off"><a class="lien-publier" href="//www.pianoweb.fr/proposer.php" rel="nofollow"><em><u>Proposez, participez...</u></em></a></div></div><br><span class="moyen-titre-blanc">Portail sur la musique et les claviers modernes : piano, synthétiseur et orgue.</span><br></div></div><div class="cadre-menu-haut"><a class="menu-haut" href="//www.pianoweb.fr">ACCUEIL</a><a class="menu-haut" href="//www.pianoweb.fr/actualite-info-musicale.php">INFOS</a><a class="menu-haut" href="//www.pianoweb.fr/espace-cours.php">COURS</a><a class="menu-haut-in" href="//www.pianoweb.fr/dossiers-musique.php">DOSSIERS</a><a class="menu-haut" href="//www.pianoweb.fr/espace-jeux.php">JEUX</a><a class="menu-haut" href="//www.pianoweb.fr/espace-media.php">M&Eacute;DIA</a><a class="menu-haut" href="//www.pianoweb.fr/services.php">SERVICES</a></div>

<div class="menu-horiz-cadre">
<div class="bouton-menu">
<a class="menu-horiz-f" href="javascript: switchInfoPerso1();">MENU</a>
</div>
<div class="bouton-accueil">
<a class="menu-horiz-d" href="//www.pianoweb.fr/nouveautes-pianoweb.php">NEWS</a>
</div>
<div class="bouton-rechercher">
<a class="menu-horiz" href="//www.pianoweb.fr/recherche-google.php" rel="nofollow">RECH.</a>
</div>
<div class="bouton-contact">
<a class="menu-horiz-b" href="//www.pianoweb.fr/contact.php" rel="nofollow">CONT.</a>
</div>
</div>

<div class="menu-horiz-cadre-2">

<div id="divacacher1" style="display: none;">

<div class="menu-horiz-cadre-g">
<a class="menu-horiz-e" href="javascript: switchInfoPerso4();">INFOS<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-e" href="javascript: switchInfoPerso2();">COURS&nbsp;<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-e" href="javascript: switchInfoPerso3();">DOSSIERS&nbsp;<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-e" href="javascript: switchInfoPerso5();">MÉDIAS&nbsp;<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-e" href="//www.pianoweb.fr/jeuxquizz-musique.php">JEUX</a><br>
<a class="menu-horiz-e" href="javascript: switchInfoPerso6();">SERVICES&nbsp;<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-e" href="javascript: switchInfoPerso8();">GLOSSAIRES&nbsp;<div class="fleche inline">&nbsp;&gt;</div></a><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso1();" rel="nofollow">Fermer</a><br><br></div>

</div>

<div class="menu-horiz-cadre-dr">

<div id="divacacher4" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/actualite-info-musicale.php">Actualité</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/info-facebook-pianoweb.php">Actu Facebook</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso4();" rel="nofollow">Fermer</a><br><br>
</div>
<div id="divacacher2" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/candide-apprendrelamusique-etlepiano.php">Questions candide</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/lecons-musique.php">Leçons gratuites</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/pedagogie-delamusique.php">Réflexions pédagogiques</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/le-courrier-des-internautes.php">Courrier internautes</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/temoignage-de-musiciens.php">Les musiciens ont la parole</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso2();" rel="nofollow">Fermer</a><br><br>
</div>
<div id="divacacher3" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/materiels-musique.php">Matériels</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/analyse-musicale.php">Analyse</a><br ><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/histoire-delamusique.php">Histoire</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/technique-etmusiqueenmao.php">Technique</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/testlogiciel-etmethodedemusique.php">Tests</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/le-saviez-vous.php">Le saviez-vous&nbsp;?</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/dossierdivers-musique.php">Dossiers divers</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso3();" rel="nofollow">Fermer</a><br><br>
</div>
<div id="divacacher5" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/demos-synthetiseurscartessonssamples.php">Démos synthés</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/videos-pedagogiques-sommaire.php">Vidéos</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/piano-cinema.php">Piano et cinéma</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/radios-piano-web.php">Radios</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso5();" rel="nofollow">Fermer</a><br><br>
</div>
<div id="divacacher6" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/proposer.php" rel="nofollow">Proposer</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/adressesutiles-musique.php">Adresses utiles</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/papier-musique.php">Papier musique</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/partitionspiano-gratuites.php">Partitions</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/accueil-annuaire.php">Annuaire</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso6();" rel="nofollow">Fermer</a><br><br>
</div>
<div id="divacacher8" style="display: none;">
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-du-home-studio.php" rel="nofollow">Home-studio</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-MAO-musiqueassistee-parordinateur.php">Musique MAO</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/lexique-des-nuances-musicales-italien-et-allemand.php">Nuances et notations étrangères</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-lexique-du-piano-acoustique.php">Piano acoustique</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-du-sequenceur.php">Séquenceur</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-lexique-du-solfege-et-de-la-theorie-musicale.php">Solfège/Théorie</a><br><br>
<a class="menu-horiz-g" href="//www.pianoweb.fr/glossaire-du-synthetiseur-analogique.php">Synthé analogique</a><br><br>
<a class="menu-horiz-h" href="javascript: switchInfoPerso8();" rel="nofollow">Fermer</a><br><br>
</div>
</div>

<div class="cadre-logo">
<a href="https://www.pianoweb.fr"><img src="data:image/gif;base64,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" width="200" height="40" alt="Piano Web"></a><br><br>
</div>

</div>


<noscript><style>.page {display:none;}</style><div class="activer-javascript"><p>Ce message vous informe que votre navigateur n'est pas en mesure de lire le 'javascript'. Or celui-ci est nécessaire pour utiliser certaines fonctions du site&nbsp;: moteur de recherche, menu, etc. Si vous ne savez pas comment activer le 'javacript', vous trouverez des infos utiles en fonction du navigateur que vous utilisez en <a class="b" href="https://www.pianoweb.fr/page-java-script.php">CLIQUANT ICI</a></p></div></noscript>

<div class="page">
<div class="cadre-page">

<div class="titre-h1">
<hr><p class="b">TECHNIQUE ET MAO</p><hr><br><h1>6 - LES CODES MIDI&nbsp;: PROGRAM CHANGES, MESSAGES SYSTÈMES ET SYSEX</h1>
</div>

<div class="menu-droit-off"><div class="mv-1">

<div class="mv-titre"><a class="moteur-de-recherche" href="//www.pianoweb.fr/recherche-google.php" rel="nofollow">RECHERCHER</a></div>
<div class="mv-titre"><a class="nouveaute" href="//www.pianoweb.fr/nouveautes-pianoweb.php">LES NOUVEAUTÉS</a></div>

<div class="mv-2"><div class="espace-100"></div><div class="mv-titre texte-blanc">Infos Musicales</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/actualite-info-musicale.php">INFOS PIANOWEB</a><a class="mv-3" href="//www.pianoweb.fr/info-facebook-pianoweb.php"> INFOS 'PAGE FACEBOOK'</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Espace Cours</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/candide-apprendrelamusique-etlepiano.php">LES QUESTIONS DU CANDIDE</a><a class="mv-3" href="//www.pianoweb.fr/lecons-musique.php">LEÇONS GRATUITES</a><a class="mv-3" href="//www.pianoweb.fr/le-courrier-des-internautes.php">COURRIER DES INTERNAUTES</a><a class="mv-3" href="//www.pianoweb.fr/temoignage-de-musiciens.php">TÉMOIGNAGES DE MUSICIENS</a><a class="mv-3" href="//www.pianoweb.fr/pedagogie-delamusique.php">PÉDAGOGIE</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Espace Dossiers</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/analyse-musicale.php">ANALYSE MUSICALE</a><a class="mv-3" href="//www.pianoweb.fr/dossierdivers-musique.php">DOSSIERS DIVERS</a><a class="mv-3" href="//www.pianoweb.fr/histoire-delamusique.php">HISTOIRE DE LA MUSIQUE</a><a class="mv-3" href="//www.pianoweb.fr/le-saviez-vous.php">LE SAVIEZ-VOUS&nbsp;?</a><a class="mv-3" href="//www.pianoweb.fr/materiels-musique.php">MATÉRIEL DE MUSIQUE</a><a class="mv-3" href="//www.pianoweb.fr/technique-etmusiqueenmao.php">TECHNIQUE ET MAO</a><a class="mv-3" href="//www.pianoweb.fr/testlogiciel-etmethodedemusique.php">TEST LOGICIEL/PROG.</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Espace Jeux</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/jeuxquizz-musique.php">TEST, QUIZZ...</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Espace Média</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/demos-synthetiseurscartessonssamples.php">DÉMOS CLAVIERS...</a><a class="mv-3" href="//www.pianoweb.fr/piano-cinema.php">LE PIANO AU CINÉMA</a><a class="mv-3" href="//www.pianoweb.fr/videos-pedagogiques-sommaire.php">VIDÉOS PÉDAGOGIQUES</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Espaces Services</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/adressesutiles-musique.php">ADRESSES UTILES &amp; ANNUAIRES</a><a class="mv-3" href="//www.pianoweb.fr/papier-musique.php">PAPIER MUSIQUE</a></div><div class="espace-100"></div>

<div class="mv-titre texte-blanc">Les Glossaires</div><div class="left"><a class="mv-3" href="//www.pianoweb.fr/glossaire-du-home-studio.php">HOME-STUDIO</a><a class="mv-3" href="//www.pianoweb.fr/glossaire-MAO-musiqueassistee-parordinateur.php">MUSIQUE MAO</a><a class="mv-3" href="//www.pianoweb.fr/lexique-des-nuances-musicales-italien-et-allemand.php">NUANCES ET NOTATIONS</a><a class="mv-3" href="//www.pianoweb.fr/glossaire-lexique-du-piano-acoustique.php">PIANO ACOUSTIQUE</a><a class="mv-3" href="//www.pianoweb.fr/glossaire-du-sequenceur.php">SÉQUENCEUR</a><a class="mv-3" href="//www.pianoweb.fr/glossaire-lexique-du-solfege-et-de-la-theorie-musicale.php">SOLFÈGE ET THÉORIE</a><a class="mv-3" href="//www.pianoweb.fr/glossaire-du-synthetiseur-analogique.php">SYNTHÉTISEUR ANALOGIQUE</a></div>

</div>

<div class="mv-titre"><div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/fr_FR/sdk.js#xfbml=1&version=v9.0" nonce="hmN2orhQ"></script>
<div class="fb-page" data-href="https://www.facebook.com/pianoweb.fr/" data-tabs="timeline" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/pianoweb.fr/" class="fb-xfbml-parse-ignore"><a class="texte-blanc" href="https://www.facebook.com/pianoweb.fr/">PianoWeb Facebook</a></blockquote></div>
</div>

<div class="mv-2"><div class="center"><a class="bouton-com" href="//www.pianoweb.fr/contact.php" target="_blank" rel="nofollow noopener noreferrer">NOUS ÉCRIRE</a></div><div class="center"><a class="bouton-com" href="//feedburner.google.com/fb/a/mailverify?uri=pianoweb" target="_blank" rel="nofollow noopener noreferrer">NEWSLETTER</a></div></div>

<div class="mv-cad-2 center fond-gris"><div class="lien-som-accueil titre-noir"><div class="center">CLAVIER VIRTUEL</div></div><span class="petit-texte-noir b">Clavier virtuel accords et gammes</span><br><a class="lien-som-accueil" href="//www.pianoweb.fr/clavier-virtuel/accordsetgammes-pianovirtuel.php"><img class="lien-som-accueil"  src="//www.pianoweb.fr/imgs/logo-clavier-virtuel-2.gif" width="255" height="110" alt="Clavier Virtuel" loading="lazy"></a><br></div>

<div class="mv-cad-2 center fond-gris"><div class="lien-som-accueil titre-noir"><div class="center">SITES PARTENAIRES</div></div><a class="lien-som-accueil" href="https://www.cadenceinfo.com"><img class="lien-som-accueil" src="//www.pianoweb.fr/imgs/cadence-info.gif" width="255" height="60" alt="CadenceInfo" loading="lazy"></a>
<div class="espace-100"></div>

<div id="div1"><ul>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/freddie-mercury-et-queen-l-histoire-d-un-groupe-de-rock-atypique.htm">FREDDIE MERCURY ET QUEEN, L'HISTOIRE DU GROUPE DE ROCK</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/nour-l-elegance-des-mots-crus.htm">NOUR : 'L'ÉLÉGANCE DES MOTS CRUS'</a></li>
<li><a class="lienrss" target="_blank" href="https://www.facebook.com/cadenceinfo.musique/posts/4683102461785841">EMILY PELLO : 'TIME SPACE LOVE'</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/la-vente-des-catalogues-d-artistes-intenationaux.htm">LE MARCHÉ DES CATALOGUES D'ARTISTES INTERNATIONAUX ET SES INVESTISSEMENTS</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/the-beatles-seconde-periode-les-innovations-musicales.htm">LES BEATLES, SECONDE PÉRIODE : LES INNOVATIONS MUSICALES SOPHISTIQUÉES</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/michael-canitrot-live-chateau-de-chantilly.htm">MICHAEL CANITROT : LIVE AU CHÂTEAU DE CHANTILLY</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/emily-pello-time-space-love-un-album-inspire-par-les-seventies.htm">EMILY PELLO ‘TIME SPACE LOVE’, UN ALBUM INSPIRÉ DES SEVENTIES</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/les-chanteuses-et-chanteurs-disparus-en-2021.htm">LES CHANTEUSES ET CHANTEURS DISPARUS EN 2021</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/les-grands-pianistes-de-l-histoire-du-jazz.htm">LES GRANDS PIANISTES DE L’HISTOIRE DU JAZZ</a></li>
<li><a class="lienrss" target="_blank" href="https://www.cadenceinfo.com/bart-et-baker-electro-swing-party.htm">BART&BAKER : 'ELECTRO SWING PARTY'</a></li>
</ul>

</div>

<a class="lien-som-accueil" href="https://www.musicmot.com"><img class="lien-som-accueil" src="//www.pianoweb.fr/imgs/music-mot.gif" width="255" height="60" alt="Music Mot" loading="lazy"></a><br></div>

<div class="image-600"><a href="https://www.pianoweb.fr"><img src="https://www.pianoweb.fr/accueil/pianoweb-untempsdavance.png" alt="Piano Web un temps d'avance" width="227" height="78"></a></div>

</div></div>
<div class="cadre-interne-2">

<div class="cadre-texte">

<p class="titre-noir">Dans une séquence MIDI, quand on souhaite automatiser certaines tâches comme le changement d’un son, le contrôle d’un pitch-bend, l’enclenchement automatisé de la pédale sustain, etc. il est bon de savoir utiliser la puissance des codes MIDI internes. Cette page explique leurs fonctionnements de base... toutefois sans se prendre la tête&nbsp;! </p>
<br>

<h2>LE RACCORDEMENT</h2> 

<p>La bonne réponse en MIDI dépend en premier lieu de l’attention avec laquelle vous raccorder les appareils entre eux (synthés, expandeurs, boîte à rythmes). Pour cela, des exemples sont proposés sur cette page&nbsp;: <a class="lien" href="apprendre-lemidi-configurations.php">Local on/off et configurations</a>. </p>

<p><span class="u">Première «&nbsp;piqure&nbsp;» de rappel</span>&nbsp;: Tout ce beau monde utilise des prises Din (180°, cinq plots) au format MIDI et non celui du DIN audio&nbsp;; l’un ne remplaçant pas l’autre. En cas de branchements fréquents, utilisez, de préférence, les modèles «&nbsp;pro&nbsp;» à connecteurs métalliques (droits ou coudés), à ceux en plastiques, plutôt fragiles.</p>

<p><span class="u">Seconde «&nbsp;piqure&nbsp;» de rappel</span>&nbsp;: la longueur des câbles doit être inférieure à quinze mètres. Partez du principe que plus une liaison par câble est courte, plus le signal sera respecté (décalage en réponse écourté).</p>
<br>

<h2>VOYAGE INITIATIQUE DANS LE MONDE MERVEILLEUX DU MIDI </h2>

<!-- MESSAGE ANTIPUB -->

<div id="message_antipub"><br><hr><p class="center"><a class="lien" href="//www.pianoweb.fr/autoriser-pianoweb.php" target="_blank" rel="nofollow"><img src="//www.pianoweb.fr/imgs/logo-adblock.png" width="300" height="75" alt="Ad Block"></a><hr><div class="vide"></div></div><div class='AdvertContainer' id="top">
<p>À présent, le matériel étant câblé proprement, à quoi va donc pouvoir nous servir ce fameux code MIDI&nbsp;?</p>

<p>À plein de choses puisque le MIDI transmet tout un tas d’information permettant, à la manière d’une télécommande, de contrôler les réglages d’un ou de plusieurs appareils à partir d’un autre. </p>

<p>Comme vous le savez peut-être déjà, le MIDI permet de véhiculer des messages sur seize canaux différents. Ces familles de messages par canal sont au nombre de sept&nbsp;: note on, note off, aftertouch, polyphonic aftertouch, pitch bend change, program change et control change. </p>

<p><span class="b">IMPORTANT</span>&nbsp;: Les informations qui suivent tiennent compte du fait que vous allez utiliser un séquenceur en vue d’optimiser et d’automatiser une séquence MIDI. Pour contrôler les données, vous devez les inscrire manuellement en début de séquence avant le début du morceau de musique, en pénétrant dans le mode d’édition de piste du séquenceur.</p>

<p>Pour vous aider à mieux saisir les explications qui suivent, et si vous êtes en possession d’une séquenceur, voici une version de <em>Billy Jean</em> de Michael Jackson en MIFIFILE. </p> 

<p>Remarque : SI vous écoutez le fichier tel quel, sans utilisation de séquenceur et sans assigneation des pistes, vous risquez d'entendre seulement un son de batterie surmonté de plusieurs pistes d'un même instrument. Ceci est tout à fait normal.</p>

<p><a class="lien" href="/technique/Billy-Jean-Michael-Jackson.zip">TELECHARGER BILLY JEAN</a></p>

<div class="image-600 strong center">
<p class="left">La capture d'écran ci-dessous montre nettement la première mesure de Billy Jean (notée AC) contenant entre autres les données de program change pour chaque piste (Séquenceur Cubase).</p>
 <img src="/technique/le-code-midi-et-ses-petits-secrets-2.gif" width="600" height="350" alt="" loading="lazy">
</div>

<h3>LES MESSAGES DE NOTES</h3>

<p>Les messages de notes permettent de régler la vélocité (vitesse d’attaque et de relâchement de la note). Chacun d’eux dispose de 128 pas de valeur. </p>
<br>

<h3>LES MESSAGES DE  PROGRAM CHANGES</h3>


<p>Concrètement, grâce aux program changes, on peut accéder (sur un canal bien précis et identique pour l’émission et la réception) aux 128 programmes d’un expandeur, via son clavier maître. En clair, on peut changer le son d’une trompette en son de piano, et revenir au son de trompette en cours de morceau en n’utilisant qu’une seule piste du séquenceur. Cette opération peut s’effectuer également pour le kit de batterie. </p>   

<p>Techniquement, il est préférable d’envoyer le message de program change un quart de mesure après le programme en cours, pour éviter de «&nbsp;couper&nbsp;» brutalement le son. De la même façon, on laisse un quart de mesure d’avance avant l’utilisation du programme suivant afin de laisser le temps au synthé d’effectuer la manœuvre en toute tranquillité.</p>

<div class="google-pub"><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2517759117673469" data-ad-slot="4078029909" data-ad-format="auto"></ins></div>

<p>Dans le cas où l’expandeur posséderait plus de 128 programmes, il est nécessaire de faire suivre un control change Bank Select d’un program change. Le premier pour préciser la banque de programme, le second pour déterminer le programme à l’intérieur de la banque en question. On peut commander jusqu’à 16384 Bank Select différents. Comme chaque bank contient 128 sons, faites le calcul… au secours, j’ai mal à la tête&nbsp;!</p>

<p>N’oublions pas que le MIDI ne véhicule pas les sons mais uniquement des données. Comme il est fréquent qu’un numéro de programme désigne un son différent d’une machine à l’autre, il est important de sauvegarder les program changes d’une séquence via le séquenceur.</p>

<p>Le format GM (General MIDI), en classifiant 128 programmes répartis en seize catégories, permet de faciliter les échanges entre machines, puisque chacune comporte la même liste de sons, la même répartition des sons de batteries et les mêmes numéros de contrôles MIDI. Cette norme permet notamment de pouvoir relire à partir de n’importe quelle machine MIDI, n’importe quelle séquence provenant de n’importe quelle autre machine. Le tout devant être au format GM pour que les informations véhiculent correctement, sans fausses notes, il va sans dire.  Pour en savoir + &nbsp;:  <a class="lien" href="standardgeneral-midi.php">Fonctionnement et utilisation du standard «&nbsp;General MIDI&nbsp;»</a>.</p>

<div class="image-600 strong">
<p class="left">La capture d'écran ci-dessous montre la mesure (AC) en mode édition, avec de haut en bas&nbsp;: les données de control change Bank Select, les effets 1 et 2 et le panoramique (pour les effets et le panoramique, la valeur 1 indique le numéro du program et la valeur 2 l'intensité de l'effet recherché).</p>

<img src="/technique/le-code-midi-et-ses-petits-secrets-1.gif" width="600" height="300" alt="" loading="lazy">
</div>

<p>Dans le cas ou votre synthétiseur ne serait pas GM, il est tout à fait possible de le reconfigurer. Il existe dans certaines marques, des programmes capables de réorganiser automatiquement les programmes internes de certaines machines au format GM. </p>

<div class="google-pub"><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2517759117673469" data-ad-slot="4078029909" data-ad-format="auto"></ins></div>
<p>Si l’on se borne à l’utilisation des 128 sons du format GM, la créativité risque de laisser place à l’uniformisation sonore. C’est là le maillon faible du GM… A moins qu’après tout, vous vous disiez qu’il existe des milliers de groupes avec les mêmes instruments&nbsp;: piano, guitare, basse, batterie, sax, trompette, etc.</p>
<br>

<h3>LES CONTROLS CHANGES</h3>

<p>Après les program changes que nous venons d'aborder, les control changes sont tout aussi indispensables. En effet, ceux-ci permettent d’affecter à une molette ou un joystick un contrôle déterminé par avance. Certains modèles de synthés récents ainsi que les claviers maîtres possèdent des potentiomètres «&nbsp;vierges&nbsp;» ou reconfigurables auxquels on assigne une fonction définie par l’utilisateur. On puise cette fonction dans les 128 contrôles possibles de la norme MIDI.</p>

<p>Ceux-ci sont divisés en trois grandes familles&nbsp;: les contrôleurs continus, les contrôleurs interrupteurs et les contrôleurs de mode. Bien utilisés, les control changes permettent bien des choses improbables et créatives (en contrôlant en temps réel filtres, modulation, panoramique, volume, etc.). On peut également changer de mode MIDI ou déclencher, via une pédale, un portamento, un sustain… Si la programmation vous effraie, pensez au confort de posséder un système fait «&nbsp;à sa main&nbsp;». En savoir +&nbsp;: <a class="lien" href="fonctionnement-des-controleurs-midi.php">Les contrôleurs MIDI et leur fonctionnement</a>.</p>

<br>

<h3>LES MESSAGES SYST&Egrave;ME</h3>

<div class="pub-250-r">
<div class="google-pub"><ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2517759117673469" data-ad-slot="4078029909" data-ad-format="auto"></ins></div></div>

<p>Parmi les messages que véhicule le MIDI, on retrouve des messages système. Ceux-ci se répartissent en trois grandes familles&nbsp;: les messages système communs qui indiquent principalement des données temporelles comme le Quarter Frame, les Song Position Pointer et le Song Select. Tout ceci étant très utile pour démarrer une séquence en un point donné. Les messages système Real Time envoient, eux, des signaux d’horloge utilisés pour la synchronisation d’un séquenceur, d’un magnéto. En savoir +&nbsp;: <a class="lien" href="http://www.pianoweb.fr/synchronisation-magnetophone-sequenceur.php">La synchronisation magnétophone/séquenceur</a>.</p>
<br>

<h3>LES MESSAGES SYSEX</h3>

<p>Enfin, nous trouvons les messages SysEX (système exclusif). Ceux là offrent aussi de grands services. Avec un peu de pratique, on peut facilement transformer un «&nbsp;bête&nbsp;» séquenceur en machine de course. </p>

<p>Exemple&nbsp;: vous avez un séquenceur, un clavier maître et trois expandeurs. Il existe de fortes probabilités pour que chacun de vos morceaux ne commence pas avec les mêmes banques de sons et les mêmes configurations multitimbrales à l’intérieur de vos expandeurs, n'est-ce pas&nbsp;?</p>

<p>Plutôt que de se taper la recherche des présets choisis (pour chaque machine) avant chaque séquence, il suffit d’enregistrer des SysEx. Pour cela, créez un pattern «&nbsp;zéro&nbsp;» dans lequel vous allez enregistrer les systèmes exclusifs de toutes vos machines (les procédures de dump sont d’une complexité effroyable, du genre Dump/envoi OK&nbsp;?). Pour ne pas avoir de problèmes, utilisez une piste pour chaque expandeur et n’envoyez pas tout les  SysEx en même temps, mais plutôt les uns à la suite des autres.</p>

<p>Un SysEx permet d’enregistrer aussi une banque de sons ou un son en particulier. Cela veut dire que si, trois semaines après l’avoir créé, vos synthés n’ont plus la même banque de son interne, il suffira d’envoyer ce pattern «&nbsp;zéro&nbsp;», qui transmettra à son tour les SysEx à chaque machine, qui se réinitialiseront avec les bons présets, dans la bonne configuration multitimbrale. Magie et gain de temps assuré&nbsp;!</p>
<br>

<h4>EN CONCLUSION</h4>

<p>Le MIDI est simple à condition d’y aller progressivement, en réalisant des tests pour voir les effets produits. Avec le MIDI, il n’y a aucun risque de causer des dégâts électroniques internes, sauf celui de déprogrammer un son ou un effet. Dans ce cas éteignez ou réinitialiser l’appareil en question pour retrouver les paramètres d’origines. Une fois que vous serez maîtriser la portée des program changes, control changes et envoi de SysEx, vous verrez que vous ne pourrez plus vous en passer. Vous finirez même par aimer le MIDI, si ça s’trouve&nbsp;!</p>  
<br>

<p>SUITE : <a class="h4" href="fonctionnement-des-controleurs-midi.php">7 - LES CONTR&Ocirc;LEURS MIDI ET LEUR FONCTIONNEMENT</a></p>
<br>

</div>

<div class="cadre-lien-retour"><a class="lien-som-dossiers" href="technique-etmusiqueenmao.php#midi"><div class="titre-blanc center">DOSSIER "LE SYST&Egrave;ME MIDI"</div></a><a class="lien-som-dossiers" href="dossiers-musique.php#sommaire"><div class="titre-blanc center">SOMMAIRE "DOSSIERS"</div></a><a class="mv" href="//www.pianoweb.fr"><div class="gros-titre-blanc center">ACCUEIL</div></a></div>

</div></div><div class="cadre-interne-1">

<div class="vide"></div>

<div class="cadre-bdp-google"><ins class="adsbygoogle" data-ad-format="autorelaxed"  style="display:block" id="bandeau-google-h" data-ad-client="ca-pub-2517759117673469"  data-ad-slot="6562434349"></ins></div>

<div class="cad-fleche-1"><div class="cad-bookmarker"><div class="moyen-titre-noir">PARTICIPER/PUBLIER&nbsp;: <a class="lien" href="//www.pianoweb.fr/proposer.php" rel="nofollow">EN SAVOIR PLUS</a></div></div>

<div class="logos-communautaires">

<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pianoweb.fr%2F&amp;src=sdkpreparse" class="fb-xfbml-parse-ignore" rel="nofollow noopener noreferrer"><img src="data:image/gif;base64,R0lGODlhUAAcAKIAADpYl/3+/pusys7W5FVyprjF2nmQuejt8yH5BAAAAAAALAAAAABQABwAQAP/CLrc/jDKSekIuFR5MNmP4IEP0WkGpgZFGnwKgQ1CLRDXoeTiC7iGk+IkOlwCBpJyyWw6n9CnS1XoqT7Hq3UGyFK7K9YvfCAUCTLxEg37JQmGtmHehtNj83gD3sbrAWwxgVGEhVGDholKaRpRR089fUxCDIwudRlmGAY5OwEHPUlAlESfPQJMjAA9BQUZAB2fB2VHsx04GLOZsbyruSoGPb5IP5KKx8jJysvMzc7P0M4mr1IFA09mA8ZKM39OnU6RTrifLZwDVUkKAgNGqD/tNJ4B8Tfr9QsGBUYFH5er6LZF0GQKTg1XAW50qzFNW6QjNXK5GMDJA8RTl3IIlKAKT2A7DAL+xQizSSMYUJvGJCTFYouOJq8iWUoJqCOgk4A6HHCBKlSnmTs7XJskhpwuFLE+ofFSBqEKbT+S7gTk9ACKERrnRNvKtavXr2AJJQAAOw==" alt="Facebook" width="80" height="28"></a>&nbsp;

<a href="https://twitter.com/pianoweb_info?ref_src=" target="_blank" rel="nofollow noopener noreferrer"><img src="data:image/gif;base64,R0lGODlhUAAcAKIAADPM/////9Hz/3Tc/0vS/5Dj/z3O//D7/yH5BAAAAAAALAAAAABQABwAQAPACLrc/jDKSau9eIaRQfig8hXg9h1ekIZrIKTOp3BNWXZ4ru9879c2kUGkEhFgQVtBcWAtnLZooED7Wa/YrHbLxcgysi+xCBa3yJYPYX1kfUPhAHu1JioE8UP9KXVeSkMABm9TTy93ZlBuVWNRh12QkZKTlJWWl5iZmjyBZRCMGKAAeGZpaBaHiaUXTXFBf31FhCqusWeyrwSxIEsVpW64tMKdflIwD7uhUbc3x0k3xmIHLyR9mz6kq9fb3N3e31sJADs=" alt="Twitter" width="80" height="28"></a>&nbsp;

<a href="https://www.youtube.com/user/pianowebofficiel" target="_blank" rel="nofollow noopener noreferrer"><img src="  data:image/gif;base64,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" height="28" width="80" alt="YouTube"></a>

</div>

<div class="cad-fleche-g"><a  href="#"><img src="data:image/png;base64,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" width="35" height="30" alt="haut"></a></div><div class="cad-fleche-dr"><a href="#"><img src="data:image/png;base64,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" width="35" height="30" alt="haut"></a></div></div></div>

</div></div>

<div class="b-de-pag"><div class="center"><a href="https://www.pianoweb.fr"><img src="data:image/gif;base64,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" width="150" height="36" alt="Accueil"></a><div class="padding-10"><div class="petit-texte-blanc">Copyright &#169; 2003-2022 - Piano Web All rights reserved<br><br>
Ce site est protégé par la <a class="lien-blanc" href="https://www.sgdl.org/" rel="nofollow noopener noreferrer" target="_blank">"<u>Société des Gens de Lettres</u>"</a><br><br><a class="lien-blanc" href="https://www.pianoweb.fr/references-pianoweb.php" rel="nofollow"><u>Nos références sur le Web</u></a>&nbsp;-&nbsp;<a class="lien-blanc" href="https://www.pianoweb.fr/copyright.php" rel="nofollow"><u>©&nbsp;Copyright &amp; Mentions légales</u></a></div></div>

<div id="bottom"></div>
<a class="logo-rechercher" href="https://www.pianoweb.fr/recherche-google.php" rel="nofollow noopener noreferrer"></a>
<a class="logo-news" href="https://www.pianoweb.fr/nouveautes-pianoweb.php" rel="noopener noreferrer"></a>
<a class="fleche-hautdepage" href="#"></a><a class="fleche-basdepage" href="#bottom"></a>
<a class="logo-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pianoweb.fr%2F&amp;src=sdkpreparse" target="_blank" rel="nofollow noopener noreferrer"></a>
<a class="logo-twitter" href="https://twitter.com/pianoweb_info?ref_src=" target="_blank" rel="nofollow noopener noreferrer"></a>
<a class="logo-youtube" href="https://www.youtube.com/user/pianowebofficiel" target="_blank" rel="nofollow noopener noreferrer"></a>
</div>
<!--[if IE 9]></div><![endif]-->

<script>
//	boutons twitter et google
eval(function(p,a,c,k,e,r){e=function(c){return(c<a?'':e(parseInt(c/a)))+((c=c%a)>35?String.fromCharCode(c+29):c.toString(36))};if(!''.replace(/^/,String)){while(c--)r[e(c)]=k[c]||e(c);k=[function(e){return r[e]}];e=function(){return'\\w+'};c=1};while(c--)if(k[c])p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c]);return p}('(5(){0 b=5(3,6,7,8){0 9=7||q;0 a=8||r;0 c=1.s||1.t;0 d=1.u||1.v;0 f=1.w||4.g.x;0 h=1.y||4.g.z;0 i=c+f/2-9/2;0 j=d+h/2-a/2;0 k=1.A(3,6,\'B=C, 7=\'+9+\', 8=\'+a+\', D=\'+j+\', E=\'+i);k.F();G H};4.I(\'.J-l\').K(\'L\',5(e){e.M();0 3=N.O(\'P-3\');0 m="n://l.o/Q/R?S="+T(4.6)+"&U=p"+"&3=n://V.p.o";b(m,"W")})})();',59,59,'var|window||url|document|function|title|width|height|popupWidth|popupHeight|popupCenter|windowLeft|windowTop||windowWidth|documentElement|windowHeight|popupLeft|popupTop|popup|twitter|shareUrl|https|com|cadenceinfo|640|320|screenLeft|screenX|screenTop|screenY|innerWidth|clientWidth|innerHeight|clientHeight|open|scrollbars|yes|top|left|focus|return|true|querySelector|logo|addEventListener|click|preventDefault|this|getAttribute|data|intent|tweet|text|encodeURIComponent|via|www|Twitter'.split('|'),0,{}))
	
eval(function(p,a,c,k,e,r){e=function(c){return(c<a?'':e(parseInt(c/a)))+((c=c%a)>35?String.fromCharCode(c+29):c.toString(36))};if(!''.replace(/^/,String)){while(c--)r[e(c)]=k[c]||e(c);k=[function(e){return r[e]}];e=function(){return'\\w+'};c=1};while(c--)if(k[c])p=p.replace(new RegExp('\\b'+e(c)+'\\b','g'),k[c]);return p}('(5(){0 7=5(1,8,9,a){0 b=9||z;0 c=a||A;0 f=3.B||3.C;0 g=3.D||3.E;0 h=3.F||4.i.G;0 j=3.H||4.i.I;0 k=f+h/2-b/2;0 l=g+j/2-c/2;0 m=3.J(1,8,\'K=L, 9=\'+b+\', a=\'+c+\', M=\'+l+\', N=\'+k);m.O();P Q};4.n(\'.o-p\').q(\'r\',5(e){e.s();0 1=t.u(\'v-1\');0 6="d://p.w/R/S?T="+x(4.8)+"&U=V"+"&1=d://W.X";7(6,"Y")});4.n(\'.o-y\').q(\'r\',5(e){e.s();0 1=t.u(\'v-1\');0 6="d://Z.y.w/10?1="+x(1);7(6,"11+")})})();',62,64,'var|url||window|document|function|shareUrl|popupCenter|title|width|height|popupWidth|popupHeight|https||windowLeft|windowTop|windowWidth|documentElement|windowHeight|popupLeft|popupTop|popup|querySelector|logo|twitter|addEventListener|click|preventDefault|this|getAttribute|data|com|encodeURIComponent|google|580|360|screenLeft|screenX|screenTop|screenY|innerWidth|clientWidth|innerHeight|clientHeight|open|scrollbars|yes|top|left|focus|return|true|intent|tweet|text|via|pianoweb_info|pianoweb|fr|Twitter|plus|share|Google'.split('|'),0,{}))


function switchInfoPerso1() {divInfo = document.getElementById('divacacher1'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';} 
function switchInfoPerso2() {divInfo = document.getElementById('divacacher2'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';} 
function switchInfoPerso3() {divInfo = document.getElementById('divacacher3'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';} 
function switchInfoPerso4() {divInfo = document.getElementById('divacacher4'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';} 
function switchInfoPerso5() {divInfo = document.getElementById('divacacher5'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';} 
function switchInfoPerso6() {divInfo = document.getElementById('divacacher6'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}  
function switchInfoPerso7() {divInfo = document.getElementById('divacacher7'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}  
function switchInfoPerso8() {divInfo = document.getElementById('divacacher8'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}
function switchInfoPerso9() {divInfo = document.getElementById('divacacher9'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}
function switchInfoPerso10() {divInfo = document.getElementById('divacacher10'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}
function switchInfoPerso11() {divInfo = document.getElementById('divacacher11'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}
function switchInfoPerso12() {divInfo = document.getElementById('divacacher12'); if (divInfo.style.display == 'none') divInfo.style.display = 'block'; else divInfo.style.display = 'none';}

</script>

<script>
!function(e){if(e.cookieChoices)return e.cookieChoices;var c,l,d,s=e.document,o="textContent"in s.body,t=(c="displayCookieConsent",l="cookieChoiceInfo",d="cookieChoiceDismiss",{showCookieConsentBar:function(e,t,o,n){i(e,t,o,n,!1)},showCookieConsentDialog:function(e,t,o,n){i(e,t,o,n,!0)}});function n(e,t){o?e.textContent=t:e.innerText=t}function p(e){var t=s.createElement("span");return n(t,e),t}function u(e){var t=s.createElement("a");return n(t,e),t.id=d,t.href="#",t.style.color="#FFCC00",t.style.marginLeft="3px",t}function C(e,t){var o=s.createElement("a");return n(o,e),o.href=t,o.target="_blank",o.style.color="#FFCC00",o.style.marginLeft="4px",o}function h(){var e;return(e=new Date).setFullYear(e.getFullYear()+1),s.cookie=c+"=y; expires="+e.toGMTString(),f(),!1}function i(e,t,o,n,i){var r,a;s.cookie.match(new RegExp(c+"=([^;]+)"))||(f(),r=i?function(e,t,o,n){var i=s.createElement("div");i.id=l;var r=s.createElement("div");r.style.cssText="position:fixed;width:100%;height:100%;z-index:999;top:0;left:0;opacity:0.5;filter:alpha(opacity=50);background-color:#000;color:#FFF;";var a=s.createElement("div");a.style.cssText="position:relative;left:-50%;margin-top:-25%;background-color:#000;color:#FFF;padding:20px;box-shadow:4px 4px 25px #888;";var c=s.createElement("div");return c.style.cssText="z-index:1000;position:fixed;left:50%;top:50%",(t=u(t)).style.display="block",t.style.textAlign="right",t.style.marginTop="8px",a.appendChild(p(e)),o&&n&&a.appendChild(C(o,n)),a.appendChild(t),c.appendChild(a),i.appendChild(r),i.appendChild(c),i}(e,t,o,n):(e=e,r=t,o=o,n=n,(a=s.createElement("div")).id=l,a.style.cssText="position:fixed;width:100%;background-color:#000;color:#FFF;margin:0; bottom:0;padding-top:30px;padding-bottom:25px;font-size:90%;letter-spacing: 1px;z-index:1000;text-align:center;",a.appendChild(p(e)),o&&n&&a.appendChild(C(o,n)),a.appendChild(u(r)),a),(a=s.createDocumentFragment()).appendChild(r),s.body.appendChild(a.cloneNode(!0)),s.getElementById(d).onclick=h)}function f(){var e=s.getElementById(l);null!=e&&e.parentNode.removeChild(e)}e.cookieChoices=t}(this),document.addEventListener("DOMContentLoaded",function(e){cookieChoices.showCookieConsentBar("En poursuivant votre visite sur notre site, vous acceptez l'utilisation de cookies permettant la diffusion de publicité ciblée non-intrusive.","[J'accepte]","[Contrôler les cookies]","//www.cnil.fr/vos-droits/vos-traces/les-cookies/")});
</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script> (adsbygoogle = window.adsbygoogle || []).push({});  (adsbygoogle = window.adsbygoogle || []).push({});  (adsbygoogle = window.adsbygoogle || []).push({});  (adsbygoogle = window.adsbygoogle || []).push({}); </script>

<div id="Ad9fb8f4ac145dc317be75699df9bbB" class="avertissement-popup-1">	<div class="avertissement-popup-2"><span class="avertissement-popup-3">&times;</span><p>Si une extension de type 'Adblock' (ou assimilée) est installée sur votre navigateur, celle-ci empêchera de consulter certaines pages de ce site dans leur intégralité. La mise en ligne d'encarts publicitaires non intrusifs permet à ce site collaboratif d'exister durablement. Pour obtenir un accès total, vous devez désactiver l'extension. </p></div></div>
<script src="https://altsysimg.developpez.com/show_i.php?tstnew"></script><script> if (!document.getElementById("A70b404B") && document.cookie.indexOf("warnadb=") == -1) {
	document.cookie = "warnadb=1;max-age=28800"; document.getElementById("Ad9fb8f4ac145dc317be75699df9bbB").style.visibility = "visible"; document.querySelector("#Ad9fb8f4ac145dc317be75699df9bbB span").addEventListener("click", function() {	document.getElementById("Ad9fb8f4ac145dc317be75699df9bbB").style.visibility = "hidden";	});}</script>
</div></div></div></body></html>